
 

ArtRage 5 Information for Reviewers 

We are very pleased to announce the upcoming release of ArtRage 5, our most powerful 

and professional edition of ArtRage yet. ArtRage 5 will be available in January 2017 directly 

from ArtRage.com.  

We hope you enjoy reviewing the latest version of our software. If you have any questions 

or comments, please feel free to contact us at support@artrage.com  

ArtRage is a traditional media painting program that mimics real life painting and drawing. 

ArtRage offers incredibly realistic oils, pencils, watercolor, canvas textures and other 

traditional painting tools, along with a range of powerful professional features and digital 

editing functions. 

It is designed to be accessible to a wide range of users and support professional quality 

illustration while remaining focused on traditional media. It is created by the company 

‘Ambient Design’, which is based in New Zealand and has been around since 2004. 

The first paid version, ArtRage 2, was released in 2006, and ArtRage 4 was released in early 

2012. We bring out a major .5 update approximately halfway through each edition, which 

includes significant new features. Minor updates to address bugs and other issues are 

released for free as they are needed. 

ArtRage’s desktop software can be installed on Windows and Mac OSX.  

In this document: 

· Buying ArtRage 5 (Editions, Price and Upgrades) 

· Summary of New Features 

· In depth guide to new features with images  

 

·  

mailto:support@artrage.com


Buying ArtRage 5 

Release: January 2017 www.artrage.com 

Other Editions 

ArtRage 5 will be the full professional edition complete with new features, and ArtRage Lite is an 

introductory version for beginners. 

ArtRage 4 will be discontinued after ArtRage 5 is released. ArtRage Lite will still be available as an 

introductory edition and offers a perpetual licence. This means that ArtRage Lite will always be up to 

date, and always include an upgrade discount to the latest full edition of ArtRage. 

ArtRage is currently available as a paid app for iPad and Android, as well as a free oil painting app on 

Android. ArtRage Lite is also available free with the Wacom Intuos Draw tablets.  

Price:  

ArtRage 5 will be $79. ArtRage Lite will remain the same price ($30). 

Upgrades 

Existing ArtRage desktop users can upgrade from any previous desktop version of ArtRage, including 

ArtRage 2 and ArtRage Lite.  

ArtRage 2, ArtRage 3 (Studio and Studio Pro) and ArtRage 4 users can upgrade to ArtRage 5 at a 50% 

discount ($39.50 off). 

Sale 

ArtRage 4 and ArtRage Lite will be on sale until ArtRage 5 is released. 

Any user who purchases ArtRage 4 or ArtRage Lite during the 50% off sale will also get 50% off when 

upgrading to ArtRage 5. This means that they will get a guaranteed discount on the final purchase 

cost. 

System Support: 

ArtRage 5 will support Windows Vista, 7, 8 and 10, Mac OS 10.8 and later. It includes 64-bit support 

and the same range of languages as ArtRage 4 (English, French, German, Dutch, Spanish, Italian, 

Japanese, Russian). It will not require a more powerful computer to run. 

ArtRage 5: Summary of New Features 

What’s coming in ArtRage 5? So many things, and we’re very excited to be able to talk about them at 

last! 

 

New Tools 



ArtRage 5 comes with several major new editing and painting tools, including a custom brush 

designer, Perspective, Guides, and a much more realistic Pencil tool.  ArtRage 5 includes 

additional image editing effects allowing you to add highlights, dropshadows, emboss, and 

liquefy effects to a layer. This edition also offers improved speed and processing power, so 

ArtRage now performs even better at larger sizes. 

 Custom Brush Tool  

 Custom Brush Designer  

 More Realistic Pencil and Pastel 

 Layer Effects  

 Warp  

 Perspective  

 Guides  

 Snap Distance for Grids/Guides/Perspective 

 

Improved Interface: 

The entire interface has been redesigned to create a cleaner and more intuitive workspace. Along 

with a complete reworking of every icon and menu, ArtRage 5 includes a vastly improved version of 

the old ‘workbench’ mode that allows you to fully customize your workspace with floating and 

docking panels. You can toggle the entire interface into ‘Lights Out’ which gives you a darker 

interface. 

We’ve also added some workflow improvements like the ability to rotate your entire painting from 

the Edit menu, redesigned the way Transform works, a better Layers menu, and the ability to work 

with multiple documents at once. 

 UI Redesign  

 Docking Mode  

 Lights Out mode 

 Multiple Documents  

 Transform 

 

 

 

 

 

 

 



A Closer Look at the New Features & Improvements in ArtRage 5 

Coming in January 2017. Find out more at www.artrage.com 

The rest of this document introduces you to the new features. For additional resources, see 

www.artrage.com/press-section/ or contact Ambient Design directly.  

1. Custom Brush Tool & Custom Brush Designer  

2. More Realistic Pencil and Pastel 

3. Layer Effects  

4. Layout Panel: Perspective, Guides, Snap Distance for Grids/Guides/Perspective  

5. Warp  

6. UI Redesign  

7. Docking Mode  

8. Lights Out 

9. Multiple Documents  

10. Improved Performance 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.artrage.com/
http://www.artrage.com/press-section/


 

1. Custom Brush 

The Custom Brush brings the power of customisable pixels into ArtRage, allowing users to create 

their favourite purely digital brushes and effects. You can choose from a wide range of presets or 

create your own brushes. 

 The Custom Brush designer allows you to select bitmaps to use for brush heads and masks, and 

adjust a huge array of sliders relating to stroke and dab properties. It differs from the existing sticker 

spray in that it is a purely digital media tool that doesn’t rely on ArtRage’s natural media properties, 

and should be more suitable for custom brush designs. 

 

 



 

 

Image Credit: Sav Scatola www.boxy.co.uk (please include if using this image) 

 

 

 

 

 

 

 

 

http://www.boxy.co.uk/


2. More Realistic Pencil and Pastel 

The Pencil and the Pastel (Wax/Chalk) tool now have improved appearance and handling for more 

natural effects, adding to the existing live tilt support and allowing a softer touch and the use of a 

wider range of traditional sketching and shading techniques. 

You can now create any kind of sketching pencil or adjust the settings for soft or hard coloring 

pencils. The pastel feels more natural and realistic than ever, and the chalk mode now offers a 

fantastic charcoal effect. 

This is achieved through adjustable Noise in the tool settings, which allows you to increase the 

amount and scale of internal variation and affects the way the media interacts with the paper. 

Additional pencil, pastel and chalk/charcoal artwork: 

https://www.facebook.com/116580331699607/photos/?tab=album&album_id=1363907766966851 

 

 

https://www.facebook.com/116580331699607/photos/?tab=album&album_id=1363907766966851


 

 



 



3. Layer Effects 

Use Layer Effects to add shadows, glow, cutout and emboss effects to individual layers and text.  

ArtRage now includes a range of popular highlight and shadow effects that can be applied to both 

text and paint. You can cycle through effects using Shift + F9, change the direction using Ctrl +F9 and 

even load custom textures. You can also customise color, opacity, radius, lighting, blend modes, and 

more. 

Layer effects can be edited from the Layers menu. 

 

 

Image Credit: Sav Scatola www.boxy.co.uk (please include if using this image) 

 

http://www.boxy.co.uk/


 

 

 

 

 

 



4. Layout: Grids, Guides, and Perspective 

ArtRage 5 offers a significantly expanded range of guideline features to assist in design and 

composition, adding Guides and Perspective to the existing Grids feature. All offer customizable 

appearance properties (colour, opacity, on/off visibility), a ‘snap to’ line drawing feature with 

variable distance strength that can be adjusted independently for grids, guides and perspective, and 

the ability to set up and save custom sets. 

The layout guides can be accessed through the View > Layout Panel menu or through the 

‘crosshatch’ shortcut in the top menu bar. 

 

 

Perspective: 

Perspective lets you use one or two point perspective, loading the default sets or adding your own 

individual walls and floors around the horizon line then saving them for later use. You can customise 

the appearance and add or remove any line or section, as well as using ‘Snap to Perspective’ to help 

you draw. 

You can also apply perspective when copy/pasting and transforming. 

 



 

 

 



 

Image Credit: Sav Scatola www.boxy.co.uk (please include if using this image) 

 

Guides: 

Guides let you mark out horizontal and vertical guidelines across the page. You can position lines 

manually or automatically frame existing paint on a layer and use the ‘Snap To’ function to draw 

along the line. 

Open the Layout Panel and switch to the middle tab for the Guides, or use the three shortcut 

buttons in the top left of the screen. 

 

http://www.boxy.co.uk/


 

 

 

Snap To Line 

The 'snap to' feature allows you to draw straight lines along the grid, guide or perspective. This was 

existed as part of the Grids feature in ArtRage 4.5, but now there's a new 'sensitivity' slider that lets 

you adjust how strong the ‘snap’ effect is. 

You can adjust the snap strength individually for grids, perspective and guides. 

 



5. Warp 

You can now distort your image using the popular ‘liquefy’ effect, using the preview panel and 

options to get exactly the result you want in a high speed fullscreen warp mode. You can adjust size, 

softness, and rotation, as well as selectively undoing warped areas. 

Access the warp mode by going to Edit > Warp. 

 

 

Image Credit: Sav Scatola www.boxy.co.uk (please include if using this image) 

 

 

http://www.boxy.co.uk/


6. Redesigned Interface 

There are also a whole range of tiny improvements that existing users should appreciate, all 

intended to make ArtRage a better creative experience. Every menu, icon and pod has been 

redesigned to create a sleeker, less obtrusive, look, while still retaining ArtRage’s traditional media 

charm and accessible interface layout. There are also various functional improvements to the 

interface.  

 

For example: 

 The layers panel is larger for easier viewing 

 You can now switch between small and large layer thumbnails in the layers panel, depending 

on whether you prefer to browse by image or by name. 

 The Presets menu is completely redesigned for easier browsing. 

 You can toggle into a precise RGB color picker in Docking Mode 

 The interface now scales automatically with your screen resolution and magnification level 

 Fullscreen (press ‘D’) no longer hides part of the canvas behind the upper menu bar 

 New canvas size is based on the size of images stored in the clipboard 

 Transform is now a fullscreen mode offering more options, scaling with active perspective, 

and better control. It can be access using the ‘transform’ icon in the upper menu bar or by 

pressing Shift + T.  

 

 



 

 

 



 

 

 

 

 

 

 

 

 



7. Docking Mode 

The default mode isn’t for everyone,  but the new docking mode should suit users that like to 

customize their workspace more extensively. 

Whether you prefer a purely minimalist interface or like arranging your most used tool menus into 

organised panels, docking mode lets you set things up the way you want, and adjust everything as 

you work, easily and quickly. 

The old Workbench mode has been completely redesigned to improve usability and flexibility for 

professional users, without losing sight of the intuitiveness and simplicity of ArtRage. Along with a 

discreet menu bar with handy drop down menus and shortcuts to the full range of tools and 

features, you can now detach individual panels and position them around your screen or drag them 

to the right and left of the screen to handy docking bars. You can also completely clear your screen 

of menu bars by pressing ‘tab’.  

 

ArtRage will remember which mode you used last and open into it automatically. 

You can enable docking mode by going to View > Interface – and we highly recommend trying it out. 



 

 

 

 

 

 

 

 



8. Lights Out 

We’ve heard our user’s feedback, and create a dark interface mode, so that you can choose the look 

that you prefer working with or that clashes the least with your artwork. 

You can turn Lights Out on by going to View > Interface, and it applies to both the default and the 

docking interfaces. 

 



9. Multiple Documents 

You can now open and work with multiple ArtRage paintings at once. Switch between them easily as 

you work using shortcuts (Ctrl + Tab and Ctrl + Shift + Tab), the dropdown menu in the workbench or 

the pop out Documents Panel.  

 

 

10. Improved Performance 

Updated code and behind the scenes software improvements mean that not only does ArtRage 

handle better than ever, but has improved crash recovery and a more secure save feature, so even if 

something causes ArtRage to shut down, you’re much less likely to lose work. 

 

 

More images & resources available from www.artrage.com/press-section/ or directly from Ambient 

Design. 
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